Kurz gesagt
- CVE-2021-4286 ist eine Schwachstelle (HOCH (CVSS 7.5)) in srp, pysrp (pysrp project).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.77%, höher als bei 55.7% aller Schwachstellen.
- Abhilfe: auf 1.0.17 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| srp PyPI | < 1.0.17
| 1.0.17
|
| pysrp | < 1.0.17
| 1.0.17
|
Description
A vulnerability, which was classified as problematic, has been found in cocagne pysrp up to 1.0.16. This issue affects the function calculate_x of the file srp/_ctsrp.py. The manipulation leads to information exposure through discrepancy. Upgrading to version 1.0.17 is able to address this issue. The name of the patch is dba52642f5e95d3da7af1780561213ee6053195f. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216875.
NVD description
A vulnerability, which was classified as problematic, has been found in cocagne pysrp up to 1.0.16. This issue affects the function calculate_x of the file srp/_ctsrp.py. The manipulation leads to information exposure through discrepancy. Upgrading to version 1.0.17 is able to address this issue. The name of the patch is dba52642f5e95d3da7af1780561213ee6053195f. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216875.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free