Kurz gesagt
- CVE-2021-43812 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in nextjs-auth0 (auth0), @auth0/nextjs-auth0.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.68%, höher als bei 52.3% aller Schwachstellen.
- Abhilfe: auf 1.6.2 oder neuer aktualisieren.
Description
Overview
Versions <=1.6.1 do not filter out certain returnTo parameter values from the login url, which expose the application to an open redirect vulnerability.
Am I affected?
You are affected by this vulnerability if you are using @auth0/nextjs-auth0 version <=1.6.1.
How to fix that?
Upgrade to version >=1.6.2
Will this update impact my users?
The fix provided in the patch will not affect your users.
NVD description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before 1.6.2 do not filter out certain returnTo parameter values from the login url, which expose the application to an open redirect vulnerability. Users are advised to upgrade as soon as possible. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free