Kurz gesagt
- CVE-2021-43835 ist eine Schwachstelle (HOCH (CVSS 7.2)) in sulu/sulu, sulu (sulu).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.2%, höher als bei 67.5% aller Schwachstellen.
- Abhilfe: auf 2.2.18, 2.3.8, 2.4.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| sulu/sulu Packagist | ≥ 2.0.0, < 2.2.18≥ 2.3.0, < 2.3.8≥ 2.4.0-RC1, < 2.4.0
| 2.2.182.3.82.4.0
|
| sulu | = 2.4.0≥ 2.0.0, < 2.2.18≥ 2.3.0, < 2.3.8
| 2.2.182.3.8
|
Description
Impact
Impacted are only users which already have access to the admin UI. Over the API it was possible for them to give themselves permissions to areas which they did not already had. This issue was introduced in 2.0.0-RC1 with the new ProfileController putAction.
Patches
The versions have been patched in 2.2.18, 2.3.8 and 2.4.0.
Workarounds
Patching the ProfileController of affected sulu versions yourself by overwriting it.
References
Are there any links users can visit to find out more?
Currently not.
For more information
If you have any questions or comments about this advisory:
NVD description
Sulu is an open-source PHP content management system based on the Symfony framework. In affected versions Sulu users who have access to any subset of the admin UI are able to elevate their privilege. Over the API it was possible for them to give themselves permissions to areas which they did not already had. This issue was introduced in 2.0.0-RC1 with the new ProfileController putAction. The versions have been patched in 2.2.18, 2.3.8 and 2.4.0. For users unable to upgrade the only known workaround is to apply a patch to the ProfileController manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free