Kurz gesagt
- CVE-2022-23499 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in typo3/cms, typo3/html-sanitizer, html sanitizer (typo3).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.47%, höher als bei 40.5% aller Schwachstellen.
- Abhilfe: auf 10.4.33, 11.5.20, 12.1.1, 1.5.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| typo3/cms Packagist | ≥ 10.0.0, < 10.4.33≥ 11.0.0, < 11.5.20≥ 12.0.0, < 12.1.1
| 10.4.3311.5.2012.1.1
|
| typo3/html-sanitizer Packagist | ≥ 1.0.0, < 1.5.0≥ 2.0.0, < 2.1.1
| 1.5.02.1.1
|
| html sanitizer | ≥ 1.0.0, ≤ 1.0.7≥ 2.0.0, < 2.1.1
| 2.1.1
|
Description
Problem
Due to a parsing issue in the upstream package masterminds/html5, malicious markup used in a sequence with special HTML CDATA sections cannot be filtered and sanitized. This allows bypassing the cross-site scripting mechanism of typo3/html-sanitizer.
Besides that, the upstream package masterminds/html5 provides HTML raw text elements (script, style, noframes, noembed and iframe) as DOMText nodes, which were not processed and sanitized further. None of the mentioned elements were defined in the default builder configuration, that's why only custom behaviors, using one of those tag names, were vulnerable to cross-site scripting.
Solution
Update to typo3/html-sanitizer versions 1.5.0 or 2.1.1 that fix the problem described.
NVD description
HTML sanitizer is written in PHP, aiming to provide XSS-safe markup based on explicitly allowed tags, attributes and values. In versions prior to 1.5.0 or 2.1.1, malicious markup used in a sequence with special HTML CDATA sections cannot be filtered and sanitized due to a parsing issue in the upstream package masterminds/html5. This allows bypassing the cross-site scripting mechanism of typo3/html-sanitizer. The upstream package masterminds/html5 provides HTML raw text elements (`script`, `style`, `noframes`, `noembed` and `iframe`) as DOMText nodes, which were not processed and sanitized further. None of the mentioned elements were defined in the default builder configuration, that's why only custom behaviors, using one of those tag names, were vulnerable to cross-site scripting. This issue has been fixed in versions 1.5.0 and 2.1.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free