Kurz gesagt
- CVE-2022-23515 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in loofah, loofah (loofah project).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.86%, höher als bei 58.5% aller Schwachstellen.
- Abhilfe: auf 2.19.1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| loofah RubyGems | ≥ 2.1.0, < 2.19.1
| 2.19.1
|
| loofah | ≥ 2.1.0, < 2.19.1
| 2.19.1
|
Description
Summary
Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs.
Mitigation
Upgrade to Loofah >= 2.19.1.
Severity
The Loofah maintainers have evaluated this as Medium Severity 6.1.
References
Credit
This vulnerability was responsibly reported by Maciej Piechota (@haqpl).
NVD description
Loofah is a general library for manipulating and transforming HTML/XML documents and fragments, built on top of Nokogiri. Loofah >= 2.1.0, < 2.19.1 is vulnerable to cross-site scripting via the image/svg+xml media type in data URIs. This issue is patched in version 2.19.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free