Kurz gesagt
- CVE-2022-24709 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in awsui/components-react (amazon), @awsui/components-react.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.69%, höher als bei 52.9% aller Schwachstellen.
- Abhilfe: auf 3.0.367 oder neuer aktualisieren.
Description
Impact
Components could potentially allow cross-site scripting (XSS) in certain circumstances. These components could render content without adequate neutralization.
Patches
Fixed in 3.0.367.
NVD description
@awsui/components-react is the main AWS UI package which contains React components, with TypeScript definitions designed for user interface development. Multiple components in versions before 3.0.367 have been found to not properly neutralize user input and may allow for javascript injection. Users are advised to upgrade to version 3.0.367 or later. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free