| Package | Affected versions | Patched versions |
|---|---|---|
| nextcloud server | = 23.0.0≥ 21.0.0, < 21.0.8≥ 22.0.0, < 22.2.4 | 21.0.822.2.4 |
Nextcloud server is an open source, self hosted cloud style services platform. In affected versions an attacker can cause a denial of service by uploading specially crafted files which will cause the server to allocate too much memory / CPU. It is recommended that the Nextcloud Server is upgraded to 21.0.8 , 22.2.4 or 23.0.1. Users unable to upgrade should disable preview generation with the `'enable_previews'` config flag.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free