Kurz gesagt
- CVE-2022-24762 ist eine Schwachstelle (MITTEL (CVSS 6.5)) in sysend.js (sysend.js project), sysend.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.68%, höher als bei 52.8% aller Schwachstellen.
- Abhilfe: auf 1.10.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| sysend.js | < 1.10.0
| 1.10.0
|
| sysend npm | < 1.10.0
| 1.10.0
|
Description
Impact
Users that use Cross-Origin communication and send sensitive information make it possible for this data to be intercepted.
This is not a big impact because it happens only on the same browser.
Patches
It has been patched in version 1.10.0
Workarounds
The only workaround is to not send sensitive information with sysend messages.
NVD description
sysend.js is a library that allows a user to send messages between pages that are open in the same browser. Users that use cross-origin communication may have their communications intercepted. Impact is limited by the communication occurring in the same browser. This issue has been patched in sysend.js version 1.10.0. The only currently known workaround is to avoid sending communications that a user does not want to have intercepted via sysend messages.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free