Kurz gesagt
- CVE-2022-24891 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in org.owasp.esapi:esapi, weblogic server (oracle), enterprise security api (owasp).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.7%, höher als bei 77.4% aller Schwachstellen.
- Abhilfe: auf 2.3.0.0 oder neuer aktualisieren.
Description
Impact
There is a potential for an XSS vulnerability in ESAPI caused by a incorrect regular expression for "onsiteURL" in the antisamy-esapi.xml configuration file that can cause URLs with the "javascript:" scheme to NOT be sanitized. See the reference below for full details.
Patches
Patched in ESAPI 2.3.0.0 and later. See important remediation details in the reference given below.
Workarounds
Manually edit your antisamy-esapi.xml configuration files to change the "onsiteURL" regular expression as per remediation instructions in the reference below.
References
Security Bulletin 8
For more information
If you have any questions or comments about this advisory:
NVD description
ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, there is a potential for a cross-site scripting vulnerability in ESAPI caused by a incorrect regular expression for "onsiteURL" in the **antisamy-esapi.xml** configuration file that can cause "javascript:" URLs to fail to be correctly sanitized. This issue is patched in ESAPI 2.3.0.0. As a workaround, manually edit the **antisamy-esapi.xml** configuration files to change the "onsiteURL" regular expression. More information about remediation of the vulnerability, including the workaround, is available in the maintainers' release notes and security bulletin.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free