Kurz gesagt
- CVE-2022-29249 ist eine Schwachstelle (HOCH (CVSS 7.5)) in io.github.javaezlib:JavaEZ, javaez (javaez project).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.75%, höher als bei 55.1% aller Schwachstellen.
- Abhilfe: auf 1.7 oder neuer aktualisieren.
Description
Impact
This weakness allows the force decryption of locked text by hackers. The issue is NOT critical for non-secure applications, however may be critical in a situation where the highest levels of security are required. This issue ONLY affects v1.6 and does not affect anything pre-1.6. Upgrading to 1.7 is advised.
Patches
The vulnerability has been patched in release 1.7.
Workarounds
Currently there is no way to fix the issue without upgrading.
References
CWE-327
CWE-328
For more information
If you have any questions or comments about this advisory:
NVD description
JavaEZ is a library that adds new functions to make Java easier. A weakness in JavaEZ 1.6 allows force decryption of locked text by unauthorized actors. The issue is NOT critical for non-secure applications, however may be critical in a situation where the highest levels of security are required. This issue ONLY affects v1.6 and does not affect anything pre-1.6. The vulnerability has been patched in release 1.7. Currently, there is no way to fix the issue without upgrading.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free