Kurz gesagt
- CVE-2022-31037 ist eine Schwachstelle (MITTEL (CVSS 5.4)) in oro/commerce, orocommerce (oroinc).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.49%, höher als bei 42.3% aller Schwachstellen.
- Abhilfe: auf 5.0.6 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| oro/commerce Packagist | ≥ 4.1.0, < 5.0.6
| 5.0.6
|
| orocommerce | ≥ 4.1.0, ≤ 4.1.17≥ 4.2.0, ≤ 4.2.11≥ 5.0.0, ≤ 5.0.3
| No fix yet |
Description
Impact
Shipping rule edit page is vulnerable to cross site scripting (XSS) payload added to UPS Surcharge field. The attacker should have permission to create or edit a shipping rule.
NVD description
OroCommerce is an open-source Business to Business Commerce application. Versions between 4.1.0 and 4.1.17 inclusive, 4.2.0 and 4.2.11 inclusive, and between 5.0.0 and 5.0.3 inclusive, are vulnerable to Cross-site Scripting in the UPS Surcharge field of the Shipping rule edit page. The attacker needs permission to create or edit a shipping rule. This issue has been patched in version 5.0.6. There are no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free