Kurz gesagt
- CVE-2022-31157 ist eine Schwachstelle (HOCH (CVSS 7.5)) in packbackbooks/lti-1-3-php-library, lti 1.3 tool library (packback).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.45%, höher als bei 39.5% aller Schwachstellen.
- Abhilfe: auf 5.0, 5.0.0 oder neuer aktualisieren.
Description
Impact
The function used to generate random nonces was not sufficiently cryptographically complex. As a result values may be predictable and tokens may be forgable.
Patches
Users should upgrade to version 5.0 immediately
Workarounds
None.
NVD description
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the function used to generate random nonces was not sufficiently cryptographically complex. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free