Kurz gesagt
- CVE-2022-36084 ist eine Schwachstelle (HOCH (CVSS 8.8)) in cruddl (aeb), cruddl.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.5%, höher als bei 74.3% aller Schwachstellen.
- Abhilfe: auf 2.7.0, 3.0.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| cruddl | ≥ 1.1.0, < 2.7.0≥ 3.0.0, < 3.0.2
| 2.7.03.0.2
|
| cruddl npm | ≥ 1.1.0, < 2.7.0≥ 3.0.0, < 3.0.2
| 2.7.03.0.2
|
Description
Impact
If a vunerable version of cruddl is used to generate a schema that uses @flexSearchFulltext, users of that schema may be able to inject arbitrary AQL queries that will be forwarded to and executed by ArangoDB.
Schemas that do not use @flexSearchFulltext are not affected.
The attacker needs to have READ permission to at least one root entity type that has @flexSearchFulltext enabled.
Patches
The issue has been fixed in version 3.0.2 and in version 2.7.0 of cruddl.
Workarounds
Users can temporarily remove @flexSearchFulltext from their schemas before they can update cruddl.
For more information
If you have any questions or comments about this advisory:
NVD description
cruddl is software for creating a GraphQL API for a database, using the GraphQL SDL to model a schema. If cruddl starting with version 1.1.0 and prior to versions 2.7.0 and 3.0.2 is used to generate a schema that uses `@flexSearchFulltext`, users of that schema may be able to inject arbitrary AQL queries that will be forwarded to and executed by ArangoDB. Schemas that do not use `@flexSearchFulltext` are not affected. The attacker needs to have `READ` permission to at least one root entity type that has `@flexSearchFulltext` enabled. The issue has been fixed in version 3.0.2 and in version 2.7.0 of cruddl. As a workaround, users can temporarily remove `@flexSearchFulltext` from their schemas.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free