Kurz gesagt
- CVE-2022-36124 ist eine Schwachstelle (HOCH (CVSS 7.5)) in avro (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.6%, höher als bei 75.2% aller Schwachstellen.
- Abhilfe: auf 0.14.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| avro | < 0.14.0
| 0.14.0
|
Description
It is possible for a Reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.
NVD description
It is possible for a Reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free