| Package | Affected versions | Patched versions |
|---|---|---|
| org.xwiki.platform:xwiki-platform-rest-server | ≥ 14.0.0, < 14.4.3≥ 14.5.0, < 14.6≥ 8.1, < 13.10.8 | 14.4.314.613.10.8 |
| xwiki | ≥ 14.0, < 14.4.3≥ 14.5, < 14.6≥ 8.1, < 13.10.8 | 14.4.314.613.10.8 |
The modifications rest endpoint does not filter out entries according to the user's rights. Therefore, information hidden from unauthorized users are exposed though the modifications rest endpoint (e.g., comments, page names...).
Users should upgrade to XWiki 14.6+, 14.4.3+, or13.10.8+. Older versions have not been patched.
No known workaround.
If you have any questions or comments about this advisory:
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free