Kurz gesagt
- CVE-2022-43441 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in sqlite3 (ghost), sqlite3.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 2.4%, höher als bei 83.8% aller Schwachstellen.
- Abhilfe: auf 5.1.5 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| sqlite3 | ≥ 5.0.0, < 5.1.5
| 5.1.5
|
| sqlite3 npm | ≥ 5.0.0, < 5.1.5
| 5.1.5
|
Description
Impact
Due to the underlying implementation of .ToString(), it's possible to execute arbitrary JavaScript, or to achieve a denial-of-service, if a binding parameter is a crafted Object.
Users of sqlite3 v5.0.0 - v5.1.4 are affected by this.
Patches
Fixed in v5.1.5. All users are recommended to upgrade to v5.1.5 or later.
Workarounds
- Ensure there is sufficient sanitization in the parent application to protect against invalid values being supplied to binding parameters.
References
For more information
If you have any questions or comments about this advisory:
Credits: Dave McDaniel of Cisco Talos
NVD description
A code execution vulnerability exists in the Statement Bindings functionality of Ghost Foundation node-sqlite3 5.1.1. A specially-crafted Javascript file can lead to arbitrary code execution. An attacker can provide malicious input to trigger this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free