Kurz gesagt
- CVE-2023-30608 ist eine Schwachstelle (HOCH (CVSS 7.5)) in sqlparse, sqlparse (sqlparse project).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.98%, höher als bei 62.4% aller Schwachstellen.
- Abhilfe: auf 0.4.4 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| sqlparse PyPI | ≥ 0.1.15, < 0.4.4
| 0.4.4
|
| sqlparse | ≥ 0.1.15, < 0.4.4
| 0.4.4
|
Description
Impact
The SQL parser contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service). The vulnerability may lead to Denial of Service (DoS).
Patches
This issues has been fixed in sqlparse 0.4.4.
Workarounds
None.
References
This issue was discovered and reported by GHSL team member @erik-krogh (Erik Krogh Kristensen).
- Commit that introduced the vulnerability: e75e35869473832a1eb67772b1adfee2db11b85a
NVD description
sqlparse is a non-validating SQL parser module for Python. In affected versions the SQL parser contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service). This issue was introduced by commit `e75e358`. The vulnerability may lead to Denial of Service (DoS). This issues has been fixed in sqlparse 0.4.4 by commit `c457abd5f`. Users are advised to upgrade. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free