| Package | Affected versions | Patched versions |
|---|---|---|
| postgres advanced server | ≥ 11.1.7, < 11.18.29≥ 12.1.2, < 12.13.17≥ 13.1.4, < 13.9.13≥ 14.1.0, < 14.6.0< 10.23.33 | 11.18.2912.13.1713.9.1314.6.010.23.33 |
EnterpriseDB EDB Postgres Advanced Server (EPAS) before 14.6.0 logs unredacted passwords in situations where optional parameters are used with CREATE/ALTER USER/GROUP/ROLE, and redacting was configured with edb_filter_log.redact_password_commands. The fixed versions are 10.23.33, 11.18.29, 12.13.17, 13.9.13, and 14.6.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free