| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/gravitl/netmaker | ≥ 0.18.0, < 0.18.6< 0.17.1 | 0.18.60.17.1 |
| netmaker | ≥ 0.18.0, ≤ 0.18.5< 0.17.1 | 0.17.1 |
A Mass assignment vulnerability was found allowing a non-admin user to escalate privileges to admin user.
Issue is patched in 0.17.1, and fixed in 0.18.6+.
If Users are using 0.17.1, they should run "docker pull gravitl/netmaker:v0.17.1" and "docker-compose up -d". This will switch them to the patched users
If users are using v0.18.0-0.18.5, they should upgrade to v0.18.6 or later.
If using 0.17.1, can just pull the latest docker image of backend and restart server.
Credit to Project Discovery, and in particular https://github.com/rootxharsh , https://github.com/iamnoooob, and https://github.com/projectdiscovery
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free