Kurz gesagt
- CVE-2023-3348 ist eine Schwachstelle (MITTEL (CVSS 5.7)) in wrangler (cloudflare), wrangler.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.82%, höher als bei 57.2% aller Schwachstellen.
- Abhilfe: auf 3.1.1, 2.20.1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| wrangler | < 3.1.1
| 3.1.1
|
| wrangler npm | < 2.20.1
| 2.20.1
|
Description
Impact
The Wrangler command line tool (<[email protected] or <[email protected]) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server.
Patches
Wrangler2: Upgrade to v2.20.1 or higher.
Wrangler3: Upgrade to v3.1.1 or higher.
References
Workers SDK on Github
Wrangler docs
CVE-2023-3348
NVD description
The Wrangler command line tool (<[email protected] or <[email protected]) was affected by a directory traversal vulnerability when running a local development server for Pages (wrangler pages dev command). This vulnerability enabled an attacker in the same network as the victim to connect to the local development server and access the victim's files present outside of the directory for the development server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free