Kurz gesagt
- CVE-2023-35005 ist eine Schwachstelle (MITTEL (CVSS 6.5)) in apache-airflow, airflow (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.5%, höher als bei 74.8% aller Schwachstellen.
- Abhilfe: auf 2.6.2, 2.6.2rc1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 2.5.0, < 2.6.2≥ 2.5.0, < 2.6.2rc1
| 2.6.22.6.2rc1
|
| airflow | ≥ 2.5.0, < 2.6.2
| 2.6.2
|
Description
In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations.
This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if [webserver] expose_config is set to non-sensitive-only), and not all uncensored values are actually sentitive.
This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.
NVD description
In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations.
This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive.
This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free