Kurz gesagt
- CVE-2023-39531 ist eine Schwachstelle (MITTEL (CVSS 6.8)) in sentry, sentry (sentry).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.36%, höher als bei 29.3% aller Schwachstellen.
- Abhilfe: auf 23.7.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| sentry PyPI | ≥ 10.0.0, < 23.7.2
| 23.7.2
|
| sentry | ≥ 10.0.0, < 23.7.2
| 23.7.2
|
Description
Impact
An attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account.
Remediation
- Sentry SaaS customers do not need to take any action. Those with the highest risk will be contacted directly by Sentry.
- Self-hosted installations should upgrade to version 23.7.2 or higher.
Workarounds
There are no direct workarounds, but users should review applications authorized on their account (User Settings > Authorized Applications) and remove any that are no longer needed.
NVD description
Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 23.7.2, an attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Sentry SaaS customers do not need to take any action. Self-hosted installations should upgrade to version 23.7.2 or higher. There are no direct workarounds, but users should review applications authorized on their account and remove any that are no longer needed.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free