Kurz gesagt
- CVE-2023-45809 ist eine Schwachstelle (NIEDRIG (CVSS 2.7)) in wagtail, wagtail (torchbox).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.56%, höher als bei 46.3% aller Schwachstellen.
- Abhilfe: auf 5.0.5, 5.1.3, 4.1.9 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| wagtail PyPI | ≥ 4.2, < 5.0.5≥ 4.2.0, < 5.0.5≥ 5.1, < 5.1.3≥ 5.1.0, < 5.1.3< 4.1.9
| 5.0.55.1.34.1.9
|
| wagtail | ≥ 4.2, < 5.0.5≥ 5.1, < 5.1.3< 4.1.9
| 5.0.55.1.34.1.9
|
Description
Impact
A user with a limited-permission editor account for the Wagtail admin can make a direct URL request to the admin view that handles bulk actions on user accounts. While authentication rules prevent the user from making any changes, the error message discloses the display names of user accounts, and by modifying URL parameters, the user can retrieve the display name for any user. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin.
Patches
Patched versions have been released as Wagtail 4.1.9 (LTS), 5.0.5 and 5.1.3. The fix is also included in Release Candidate 1 of the forthcoming Wagtail 5.2 release.
Workarounds
None.
Acknowledgements
Many thanks to @quyenheu for reporting this issue.
For more information
If you have any questions or comments about this advisory:
NVD description
Wagtail is an open source content management system built on Django. A user with a limited-permission editor account for the Wagtail admin can make a direct URL request to the admin view that handles bulk actions on user accounts. While authentication rules prevent the user from making any changes, the error message discloses the display names of user accounts, and by modifying URL parameters, the user can retrieve the display name for any user. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 4.1.8 (LTS), 5.0.5 and 5.1.3. The fix is also included in Release Candidate 1 of the forthcoming Wagtail 5.2 release. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free