Kurz gesagt
- CVE-2023-46240 ist eine Schwachstelle (HOCH (CVSS 7.5)) in codeigniter4/framework, codeigniter (codeigniter).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.77%, höher als bei 55.5% aller Schwachstellen.
- Abhilfe: auf 4.4.3 oder neuer aktualisieren.
Description
Impact
If an error or exception occurs in CodeIgniter4 v4.4.2 and earlier, a detailed error report is displayed even if in the production environment. As a result, confidential information may be leaked.
Patches
Upgrade to v4.4.3 or later. See upgrading guide.
Workarounds
Replace ini_set('display_errors', '0') with ini_set('display_errors', 'Off') in app/Config/Boot/production.php.
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter is a PHP full-stack web framework. Prior to CodeIgniter4 version 4.4.3, if an error or exception occurs, a detailed error report is displayed even if in the production environment. As a result, confidential information may be leaked. Version 4.4.3 contains a patch. As a workaround, replace `ini_set('display_errors', '0')` with `ini_set('display_errors', 'Off')` in `app/Config/Boot/production.php`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free