| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.shiro:shiro-core | ≥ 2.0.0alpha1, < 2.0.0-alpha4< 1.13.0 | 2.0.0-alpha41.13.0 |
| shiro | = 2.0.0< 1.13.0 | 1.13.0 |
Apache Shiro before 1.130 or 2.0.0-alpha-4, may be susceptible to a path traversal attack that results in an authentication bypass when used together with path rewriting
Mitigation: Update to Apache Shiro 1.13.0+ or 2.0.0-alpha-4+, or ensure blockSemicolon is enabled (this is the default).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free