Kurz gesagt
- CVE-2023-48699 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in fastbots, fastbots (ubertidavide).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.74%, höher als bei 55.0% aller Schwachstellen.
- Abhilfe: auf 0.1.5 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| fastbots PyPI | < 0.1.5
| 0.1.5
|
| fastbots | < 0.1.5
| 0.1.5
|
Description
Impact
An attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function def locator(self, locator_name: str) in page.py. The vulnerable code that load and execute directly from the file without validation it's:
return eval(self._bot.locator(self._page_name, locator_name))
Patches
In order to mitigate this issue it's important to upgrade to fastbots version 0.1.5 or above.
References
Merge that fix also this issue
NVD description
fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function `def __locator__(self, locator_name: str)` in `page.py`. In order to mitigate this issue, upgrade to fastbots version 0.1.5 or above.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free