Kurz gesagt
- CVE-2023-50724 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in resque, resque (resque).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.48%, höher als bei 41.9% aller Schwachstellen.
- Abhilfe: auf 2.1.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| resque RubyGems | < 2.1.0
| 2.1.0
|
| resque | < 2.1.0
| 2.1.0
|
Description
Impact
resque-web in resque versions before 2.1.0 is vulnerable to reflected XSS through the current_queue parameter in the path of the queues endpoint.
Patches
v2.1.0
Workarounds
No known workarounds at this time. It is recommended to not click on 3rd party or untrusted links to the resque-web interface until you have patched your application.
References
https://github.com/resque/resque/issues/1679
https://github.com/resque/resque/pull/1687
NVD description
Resque (pronounced like "rescue") is a Redis-backed library for creating background jobs, placing those jobs on multiple queues, and processing them later. resque-web in resque versions before 2.1.0 are vulnerable to reflected XSS through the current_queue parameter in the path of the queues endpoint. This issue has been patched in version 2.1.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free