Kurz gesagt
- CVE-2024-2035 ist eine Schwachstelle (MITTEL (CVSS 6.5)) in zenml, zenml (zenml).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.63%, höher als bei 50.1% aller Schwachstellen.
- Abhilfe: auf 0.56.2 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| zenml PyPI | < 0.56.2
| 0.56.2
|
| zenml | < 0.56.2
| 0.56.2
|
Description
An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the active status of user accounts to false, effectively deactivating them. This issue affects version 0.55.3 and was fixed in version 0.56.2. The impact of this vulnerability is significant as it allows for the deactivation of admin accounts, potentially disrupting the functionality and security of the application.
NVD description
An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the `active` status of user accounts to false, effectively deactivating them. This issue affects version 0.55.3 and was fixed in version 0.56.2. The impact of this vulnerability is significant as it allows for the deactivation of admin accounts, potentially disrupting the functionality and security of the application.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free