Kurz gesagt
- CVE-2024-21647 ist eine Schwachstelle (HOCH (CVSS 7.5)) in puma, puma (puma).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.96%, höher als bei 61.5% aller Schwachstellen.
- Abhilfe: auf 6.4.2, 5.6.8 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| puma RubyGems | ≥ 6.0.0, < 6.4.2< 5.6.8
| 6.4.25.6.8
|
| puma | ≥ 6.0.0, < 6.4.2< 5.6.8
| 6.4.25.6.8
|
Description
Impact
Prior to versions 6.4.2 and 5.6.8, puma exhibited dangerous behavior when parsing chunked transfer encoding bodies.
Fixed versions limit the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption.
Patches
The vulnerability has been fixed in 6.4.2 and 5.6.8.
Workarounds
No known workarounds.
References
NVD description
Puma is a web server for Ruby/Rack applications built for parallelism. Prior to version 6.4.2, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies in a way that allowed HTTP request smuggling. Fixed versions limits the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption. This vulnerability has been fixed in versions 6.4.2 and 5.6.8.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free