Kurz gesagt
- CVE-2024-2213 ist eine Schwachstelle (NIEDRIG (CVSS 3.3)) in zenml, zenml (zenml).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.24%, höher als bei 15.6% aller Schwachstellen.
- Abhilfe: auf 0.56.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| zenml PyPI | < 0.56.3
| 0.56.3
|
| zenml | < 0.56.3
| 0.56.3
|
Description
An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.
NVD description
An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free