Kurz gesagt
- CVE-2024-24773 ist eine Schwachstelle (MITTEL (CVSS 6.5)) in apache-superset, superset (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.78%, höher als bei 55.9% aller Schwachstellen.
- Abhilfe: auf 3.1.1, 3.0.4 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| apache-superset PyPI | ≥ 3.1.0, < 3.1.1< 3.0.4
| 3.1.13.0.4
|
| superset | ≥ 3.1.0, < 3.1.1< 3.0.4
| 3.1.13.0.4
|
Description
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.
Users are recommended to upgrade to version 3.1.1, which fixes the issue.
NVD description
Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.
Users are recommended to upgrade to version 3.1.1, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free