Kurz gesagt
- CVE-2024-26140 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in com.yetanalytics:lrs, lrs (yetanalytics), sql lrs (yetanalytics).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.45%, höher als bei 39.1% aller Schwachstellen.
- Abhilfe: auf 1.2.17, 0.7.5 oder neuer aktualisieren.
Description
Impact
A maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser.
Patches
The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS.
Workarounds
No workarounds exist, we recommend upgrading to version 1.2.17 of the library or version 0.7.5 of SQL LRS immediately.
References
NVD description
com.yetanalytics/lrs is the Yet Analytics Core LRS Library. Prior to version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS, a maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser. The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS. No known workarounds exist.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free