Kurz gesagt
- CVE-2024-27091 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in geonode, geonode (geosolutionsgroup).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.38%, höher als bei 32.0% aller Schwachstellen.
- Abhilfe: auf 4.2.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| geonode PyPI | ≥ 3.2.1, < 4.2.3
| 4.2.3
|
| geonode | > 3.2.0, < 4.2.3
| 4.2.3
|
Description
An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed.
NVD description
GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed. This vulnerability is fixed in 4.2.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free