Kurz gesagt
- CVE-2024-27137 ist eine Schwachstelle (MITTEL (CVSS 5.3)) in org.apache.cassandra:cassandra-all, cassandra (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.28%, höher als bei 20.7% aller Schwachstellen.
- Abhilfe: auf 4.0.15, 4.1.8, 5.0.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| org.apache.cassandra:cassandra-all Maven | ≥ 4.0.2, < 4.0.15≥ 4.1.0, < 4.1.8≥ 5.0-beta1, < 5.0.3
| 4.0.154.1.85.0.3
|
| cassandra | = 5.0.0≥ 4.0.2, < 4.0.15≥ 4.1.0, < 4.1.8> 5.0.0, < 5.0.3
| 4.0.154.1.85.0.3
|
Description
In Apache Cassandra it is possible for a local attacker without access to the Apache Cassandra process or configuration files to manipulate the RMI registry to perform a man-in-the-middle attack and capture user names and passwords used to access the JMX interface. The attacker can then use these credentials to access the JMX interface and perform unauthorized operations.
This is same vulnerability that CVE-2020-13946 was issued for, but the Java option was changed in JDK10.
This issue affects Apache Cassandra from 4.0.2 through 5.0.2 running Java 11.
Operators are recommended to upgrade to a release equal to or later than 4.0.15, 4.1.8, or 5.0.3 which fixes the issue.
NVD description
In Apache Cassandra it is possible for a local attacker without access
to the Apache Cassandra process or configuration files to manipulate
the RMI registry to perform a man-in-the-middle attack and capture user
names and passwords used to access the JMX interface. The attacker can
then use these credentials to access the JMX interface and perform
unauthorized operations.
This is same vulnerability that CVE-2020-13946 was issued for, but the Java option was changed in JDK10.
This issue affects Apache Cassandra from 4.0.2 through 5.0.2 running Java 11.
Operators are recommended to upgrade to a release equal to or later than 4.0.15, 4.1.8, or 5.0.3 which fixes the issue.
Weitere Schwachstellen in org.apache.cassandra:cassandra-all
Alle anzeigen →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free