Kurz gesagt
- CVE-2024-28746 ist eine Schwachstelle (HOCH (CVSS 8.1)) in apache-airflow, airflow (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.3%, höher als bei 71.4% aller Schwachstellen.
- Abhilfe: auf 2.8.3rc1, 2.8.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 2.8.0, < 2.8.3rc1
| 2.8.3rc1
|
| airflow | ≥ 2.8.0, < 2.8.3
| 2.8.3
|
Description
Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access.
Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability
NVD description
Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access.
Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free