Kurz gesagt
- CVE-2024-2928 ist eine Schwachstelle (HOCH (CVSS 7.5)) in mlflow, mlflow (lfprojects).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 21.8%, höher als bei 97.6% aller Schwachstellen.
- Abhilfe: auf 2.11.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 2.11.3
| 2.11.3
|
| mlflow | < 2.11.3
| 2.11.3
|
Description
A Local File Inclusion (LFI) vulnerability was identified in mlflow/mlflow, specifically in version 2.9.2, which was fixed in version 2.11.3. This vulnerability arises from the application's failure to properly validate URI fragments for directory traversal sequences such as '../'. An attacker can exploit this flaw by manipulating the fragment part of the URI to read arbitrary files on the local file system, including sensitive files like '/etc/passwd'. The vulnerability is a bypass to a previous patch that only addressed similar manipulation within the URI's query string, highlighting the need for comprehensive validation of all parts of a URI to prevent LFI attacks.
NVD description
A Local File Inclusion (LFI) vulnerability was identified in mlflow/mlflow, specifically in version 2.9.2, which was fixed in version 2.11.3. This vulnerability arises from the application's failure to properly validate URI fragments for directory traversal sequences such as '../'. An attacker can exploit this flaw by manipulating the fragment part of the URI to read arbitrary files on the local file system, including sensitive files like '/etc/passwd'. The vulnerability is a bypass to a previous patch that only addressed similar manipulation within the URI's query string, highlighting the need for comprehensive validation of all parts of a URI to prevent LFI attacks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free