Kurz gesagt
- CVE-2024-29904 ist eine Schwachstelle (HOCH (CVSS 7.5)) in codeigniter4/framework, codeigniter (codeigniter).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.77%, höher als bei 55.7% aller Schwachstellen.
- Abhilfe: auf 4.4.7 oder neuer aktualisieren.
Description
Impact
A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server.
Patches
Upgrade to v4.4.7 or later. See upgrading guide.
Workarounds
- Disabling Auto Routing prevents a known attack vector in the framework.
- Do not pass invalid values to the
lang() function or Language class.
References
NVD description
CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free