Kurz gesagt
- CVE-2024-34693 ist eine Schwachstelle (MITTEL (CVSS 5.3)) in apache-superset, superset (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.6%, höher als bei 75.6% aller Schwachstellen.
- Abhilfe: auf 4.0.1, 3.1.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| apache-superset PyPI | ≥ 4.0.0, < 4.0.1< 3.1.3
| 4.0.13.1.3
|
| superset | ≥ 4.0.0, < 4.0.1< 3.1.3
| 4.0.13.1.3
|
Description
Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table. This issue affects Apache Superset before version 3.1.3 and in version 4.0.0.
Users are recommended to upgrade to version 4.0.1 or 3.1.3, both of which fix the issue.
NVD description
Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table.This issue affects Apache Superset: before 3.1.3 and version 4.0.0
Users are recommended to upgrade to version 4.0.1 or 3.1.3, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free