Kurz gesagt
- CVE-2024-39877 ist eine Schwachstelle (HOCH (CVSS 8.8)) in apache-airflow, airflow (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.7%, höher als bei 77.6% aller Schwachstellen.
- Abhilfe: auf 2.9.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 2.4.0, < 2.9.3
| 2.9.3
|
| airflow | ≥ 2.4.0, < 2.9.3
| 2.9.3
|
Description
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
NVD description
Apache Airflow 2.4.0, and versions before 2.9.3, has a vulnerability that allows authenticated DAG authors to craft a doc_md parameter in a way that could execute arbitrary code in the scheduler context, which should be forbidden according to the Airflow Security model. Users should upgrade to version 2.9.3 or later which has removed the vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free