Kurz gesagt
- CVE-2024-40453 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in squirrelly (squirrelly), squirrelly.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.1%, höher als bei 66.3% aller Schwachstellen.
- Abhilfe: auf 9.1.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| squirrelly | = 9.0.0
| No fix yet |
| squirrelly npm | ≥ 9.0.0, < 9.1.0
| 9.1.0
|
Description
squirrellyjs squirrelly v9.0.0 was discovered to contain a code injection vulnerability via the component options.varName. The issue was fixed in version 9.1.0.
NVD description
squirrellyjs squirrelly v9.0.0 and fixed in v.9.0.1 was discovered to contain a code injection vulnerability via the component options.varName.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free