Kurz gesagt
- CVE-2024-41962 ist eine Schwachstelle (MITTEL (CVSS 6.3)) in bostr (yonle), bostr.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.30%, höher als bei 22.6% aller Schwachstellen.
- Abhilfe: auf 3.0.10 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| bostr | < 3.0.10
| 3.0.10
|
| bostr npm | < 3.0.10
| 3.0.10
|
Description
Even with authorized_keys is filled with allowed pubkeys, If noscraper is enabled, It will allow anyone to use bouncer even it's pubkey is not in authorized_keys.
Impact
Patches
Available on version 3.0.10
Workarounds
Disable noscraper if you have authorized_keys being set in config
References
This line of code is the cause.
NVD description
Bostr is an nostr relay aggregator proxy that acts like a regular nostr relay. bostr let everyone in even having authorized_keys being set when noscraper is set to true. This vulnerability is fixed in 3.0.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free