Kurz gesagt
- CVE-2024-43400 ist eine Schwachstelle (MITTEL (CVSS 5.4)) in org.xwiki.platform:xwiki-platform-oldcore, xwiki (xwiki).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.49%, höher als bei 42.1% aller Schwachstellen.
- Abhilfe: auf 14.10.21, 15.5.5, 15.10.6, 16.0.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| org.xwiki.platform:xwiki-platform-oldcore Maven | ≥ 1.1.2, < 14.10.21≥ 15.0-rc-1, < 15.5.5≥ 15.6-rc-1, < 15.10.6≥ 16.0.0-rc-1, < 16.0.0
| 14.10.2115.5.515.10.616.0.0
|
| xwiki | ≥ 15.0, < 15.5.5≥ 15.6, < 15.10.6< 14.10.21
| 15.5.515.10.614.10.21
|
Description
Impact
Is it possible for a user without Script or Programming rights to craft a URL pointing to a page with arbitrary JavaScript.
This requires social engineer to trick a user to follow the URL.
Reproduction steps
- As a user without script or programming right, create a (non-terminal) document named
" + alert(1) + " (the quotes need to be part of the name).
- Edit the class.
- Add a string property named
"test".
- Edit using the object editor and add an object of the created class
- Get an admin to open
<xwiki-server>/xwiki/bin/view/%22%20%2B%20alert(1)%20%2B%20%22/?viewer=display&type=object&property=%22%20%2B%20alert(1)%20%2B%20%22.WebHome.test&mode=edit where <xwiki-server> is the URL of your XWiki installation.
Patches
This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0.
Workarounds
We're not aware of any workaround except upgrading.
References
NVD description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It is possible for a user without Script or Programming rights to craft a URL pointing to a page with arbitrary JavaScript. This requires social engineer to trick a user to follow the URL. This has been patched in XWiki 14.10.21, 15.5.5, 15.10.6 and 16.0.0.
Weitere Schwachstellen in org.xwiki.platform:xwiki-platform-oldcore
Alle anzeigen →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free