Kurz gesagt
- CVE-2024-45314 ist eine Schwachstelle (MITTEL (CVSS 5.5)) in flask-appbuilder, flask-appbuilder (dpgaspar).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.27%, höher als bei 18.4% aller Schwachstellen.
- Abhilfe: auf 4.5.1 oder neuer aktualisieren.
Description
Impact
Auth DB login form default cache directives allows browser to locally store sensitive data. This can be an issue on environments using shared computer resources.
Patches
Upgrade flask-appbuilder to version 4.5.1
Workarounds
If upgrading is not possible configure your web server to send the following HTTP headers for /login:
"Cache-Control": "no-store, no-cache, must-revalidate, max-age=0"
"Pragma": "no-cache"
"Expires": "0"
NVD description
Flask-AppBuilder is an application development framework. Prior to version 4.5.1, the auth DB login form default cache directives allows browser to locally store sensitive data. This can be an issue on environments using shared computer resources. Version 4.5.1 contains a patch for this issue. If upgrading is not possible, configure one's web server to send the specific HTTP headers for `/login` per the directions provided in the GitHub Security Advisory.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free