Kurz gesagt
- CVE-2024-45477 ist eine Schwachstelle (MITTEL (CVSS 4.6)) in org.apache.nifi:nifi-web-ui, nifi (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.75%, höher als bei 55.0% aller Schwachstellen.
- Abhilfe: auf 1.28.0, 2.0.0-M4 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| org.apache.nifi:nifi-web-ui Maven | ≥ 1.10.0, < 1.28.0≥ 2.0.0-M1, < 2.0.0-M4
| 1.28.02.0.0-M4
|
| nifi | = 2.0.0≥ 1.10.0, ≤ 1.27.0
| No fix yet |
Description
Apache NiFi 1.10.0 through 1.27.0 and 2.0.0-M1 through 2.0.0-M3 support a description field for Parameters in a Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.28.0 or 2.0.0-M4 is the recommended mitigation.
NVD description
Apache NiFi 1.10.0 through 1.27.0 and 2.0.0-M1 through 2.0.0-M3 support a description field for Parameters in a Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.28.0 or 2.0.0-M4 is the recommended mitigation.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free