Kurz gesagt
- CVE-2024-45498 ist eine Schwachstelle (HOCH (CVSS 8.8)) in apache-airflow, airflow (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.2%, höher als bei 69.1% aller Schwachstellen.
- Abhilfe: auf 2.10.1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 2.10.0, < 2.10.1≤ 2.10.0-NA
| 2.10.1
|
| airflow | = 2.10.0
| No fix yet |
Description
Example DAG: example_inlet_event_extra.py shipped with Apache Airflow version 2.10.0 has a vulnerability that allows an authenticated attacker with only DAG trigger permission to execute arbitrary commands. If you used that example as the base of your DAGs - please review if you have not copied the dangerous example; see https://github.com/apache/airflow/pull/41873 for more information. We recommend against exposing the example DAGs in your deployment. If you must expose the example DAGs, upgrade Airflow to version 2.10.1 or later.
NVD description
Example DAG: example_inlet_event_extra.py shipped with Apache Airflow version 2.10.0 has a vulnerability that allows an authenticated attacker with only DAG trigger permission to execute arbitrary commands. If you used that example as the base of your DAGs - please review if you have not copied the dangerous example; see https://github.com/apache/airflow/pull/41873 for more information. We recommend against exposing the example DAGs in your deployment. If you must expose the example DAGs, upgrade Airflow to version 2.10.1 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free