Kurz gesagt
- CVE-2024-45627 ist eine Schwachstelle (MITTEL (CVSS 5.9)) in org.apache.linkis:linkis-metadata-query-service-jdbc, linkis (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.33%, höher als bei 25.9% aller Schwachstellen.
- Abhilfe: auf 1.7.0 oder neuer aktualisieren.
Description
Affected versions:
- Apache Linkis Metadata Query Service JDBC 1.5.0 before 1.7.0
Description:
In Apache Linkis <1.7.0, due to the lack of effective filtering of parameters, an attacker configuring malicious Mysql JDBC parameters in the DataSource Manager Module will allow the attacker to read arbitrary files from the Linkis server. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis < 1.6.0 will be affected.
We recommend users upgrade the version of Linkis to version 1.7.0.
NVD description
In Apache Linkis <1.7.0, due to the lack of effective filtering
of parameters, an attacker configuring malicious Mysql JDBC parameters in the DataSource Manager Module will
allow the attacker to read arbitrary files from the Linkis server. Therefore, the parameters in the Mysql JDBC URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis < 1.7.0 will be affected.
We recommend users upgrade the version of Linkis to version 1.7.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free