Kurz gesagt
- CVE-2025-14279 ist eine Schwachstelle (HOCH (CVSS 8.1)) in mlflow, mlflow (lfprojects).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.22%, höher als bei 12.3% aller Schwachstellen.
- Abhilfe: auf 3.5.0 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 3.5.0
| 3.5.0
|
| mlflow | < 3.5.0
| 3.5.0
|
Description
MLFlow versions up to and including 3.4.0 are vulnerable to DNS rebinding attacks due to a lack of Origin header validation in the MLFlow REST server. This vulnerability allows malicious websites to bypass Same-Origin Policy protections and execute unauthorized calls against REST endpoints. An attacker can query, update, and delete experiments via the affected endpoints, leading to potential data exfiltration, destruction, or manipulation. The issue is resolved in version 3.5.0.
NVD description
MLFlow versions up to and including 3.4.0 are vulnerable to DNS rebinding attacks due to a lack of Origin header validation in the MLFlow REST server. This vulnerability allows malicious websites to bypass Same-Origin Policy protections and execute unauthorized calls against REST endpoints. An attacker can query, update, and delete experiments via the affected endpoints, leading to potential data exfiltration, destruction, or manipulation. The issue is resolved in version 3.5.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free