Kurz gesagt
- CVE-2025-22150 ist eine Schwachstelle (MITTEL (CVSS 6.8)) in undici.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.76%, höher als bei 55.4% aller Schwachstellen.
- Abhilfe: auf 5.28.5, 6.21.1, 7.2.3 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| undici npm | ≥ 4.5.0, < 5.28.5≥ 6.0.0, < 6.21.1≥ 7.0.0, < 7.2.3
| 5.28.56.21.17.2.3
|
Description
Impact
Undici fetch() uses Math.random() to choose the boundary for a multipart/form-data request. It is known that the output of Math.random() can be predicted if several of its generated values are known.
If there is a mechanism in an app that sends multipart requests to an attacker-controlled website, they can use this to leak the necessary values. Therefore, An attacker can tamper with the requests going to the backend APIs if certain conditions are met.
Patches
This is fixed in 5.28.5; 6.21.1; 7.2.3.
Workarounds
Do not issue multipart requests to attacker controlled servers.
References
NVD description
Undici is an HTTP/1.1 client. Starting in version 4.5.0 and prior to versions 5.28.5, 6.21.1, and 7.2.3, undici uses `Math.random()` to choose the boundary for a multipart/form-data request. It is known that the output of `Math.random()` can be predicted if several of its generated values are known. If there is a mechanism in an app that sends multipart requests to an attacker-controlled website, they can use this to leak the necessary values. Therefore, an attacker can tamper with the requests going to the backend APIs if certain conditions are met. This is fixed in versions 5.28.5, 6.21.1, and 7.2.3. As a workaround, do not issue multipart requests to attacker controlled servers.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free