Kurz gesagt
- CVE-2025-32379 ist eine Schwachstelle (MITTEL (CVSS 6.1)) in koa (koajs), koa.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.27%, höher als bei 19.0% aller Schwachstellen.
- Abhilfe: auf 2.16.1, 3.0.0-alpha.5 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| koa | = 3.0.0< 2.16.1
| 2.16.1
|
| koa npm | ≥ 3.0.0-alpha.1, < 3.0.0-alpha.5< 2.16.1
| 3.0.0-alpha.52.16.1
|
Description
Summary
In koa < 2.16.1 and < 3.0.0-alpha.5, passing untrusted user input to ctx.redirect() even after sanitizing it, may execute javascript code on the user who use the app.
Patches
This issue is patched in 2.16.1 and 3.0.0-alpha.5.
PoC
Coming soon...
Impact
- Redirect user to another phishing site
- Make request to another endpoint of the application based on user's cookie
- Steal user's cookie
NVD description
Koa is expressive middleware for Node.js using ES2017 async functions. In koa < 2.16.1 and < 3.0.0-alpha.5, passing untrusted user input to ctx.redirect() even after sanitizing it, may execute javascript code on the user who use the app. This issue is patched in 2.16.1 and 3.0.0-alpha.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free