Kurz gesagt
- CVE-2025-3930 ist eine Schwachstelle (MITTEL (CVSS 6.3)) in @strapi/strapi.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.69%, höher als bei 53.0% aller Schwachstellen.
- Abhilfe: auf 5.24.1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| @strapi/strapi npm | < 5.24.1
| 5.24.1
|
Description
Strapi uses JSON Web Tokens (JWT) for authentication. After logout or account deactivation, the JWT is not invalidated, which allows an attacker who has stolen or intercepted the token to freely reuse it until its expiration date (which is set to 30 days by default, but can be changed). The existence of /admin/renew-token endpoint allows anyone to renew near-expiration tokens indefinitely, further increasing the impact of this attack. This issue has been fixed in version 5.24.1.
NVD description
Strapi uses JSON Web Tokens (JWT) for authentication. After logout or account deactivation, the JWT is not invalidated, which allows an attacker who has stolen or intercepted the token to freely reuse it until its expiration date (which is set to 30 days by default, but can be changed).
The existence of /admin/renew-token endpoint allows anyone to renew near-expiration tokens indefinitely, further increasing the impact of this attack.
This issue has been fixed in version 5.24.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free